Failing to register OLEDB DLL file

Issues related to Enigma Virtual Box
Post Reply
Posts: 1
Joined: Thu Jul 03, 2014 3:19 pm

Failing to register OLEDB DLL file

Post by zxorbit » Thu Jul 03, 2014 3:28 pm


I've tried lots of things to get this to work, but don't seem to be having any luck. Basically, I have some software that uses a third party OLEDB based dataprovider to connect to a database. The database/data provider dll are all propriety and there is no official support route.

Anyway, it works fine if we use an installer or a system call to regsvr32 to register the dll before the use the provider in our [c#] code. The thing is, we'd like to make our software portable, and also avoid having admin privilege escalation, as is needed for the regsvr32 command.

I tried Reg-Free COM via manifest files, but that didn't seem to work. I'm pretty use my implementation was correct (sxstrace didn't show any errors etc), but it just wouldn't work. Then, we discovered the Enigma Virtual Box software, but that doesn't seem to work either.

No matter what I try, I cannot get the DLL to register using the virtualized registry. It does work fine if I disable registry virtualization, and run the _boxed exe as an admin...which obviously defeats the point of what we're trying to achieve.

Has anyone come across DLLs that just won't register correctly unless regsvr32 is used? Any tips of more things to try?


Posts: 1
Joined: Tue Aug 26, 2014 3:05 pm

Re: Failing to register OLEDB DLL file

Post by tone » Tue Aug 26, 2014 3:34 pm

Hi, You could run two processes at startup. One to start your app and a second to run a batch file which registers your .dll independently of your app, even unregister and delete all traces when the app is closed.

I know what you are saying and i realise this isn't a direct solution to the problem, but maybe a second best for now, until someone comes up with a solution.



Posts: 1
Joined: Mon Sep 15, 2014 9:31 am

Re: Failing to register OLEDB DLL file

Post by irag12 » Mon Sep 15, 2014 9:57 am

I have same exerience, I VirtualBoxed MinGW compiler directory, when compiling, the speed become slower

Post Reply