OCX not found when run on Virtual Machine

Post here messages if you have any problems with working of Enigma Protector
Post Reply
gibra
Posts: 10
Joined: Tue Nov 04, 2014 8:10 pm

OCX not found when run on Virtual Machine

Post by gibra » Wed Jun 23, 2021 8:22 am

I'm testing Enigma Protector trial (for next purchase) but I can't figure out how to configure the project.
If I start the 'protected' file locally it works fine, but when I transfer this file to a virtual machine and run it it tells me it can't find the OCX file or one of its components.
Where am I doing wrong ?

Both the systems are Windows 10.

I enclose the project vm_test.enigma.


P.S.
My need is to have to use EP to create executables that can be run on several hundred computers regardless of the user's permissions, because the user does not always have the permissions for a normal installation.
Attachments
vm_test.zip
(25.67 KiB) Downloaded 3 times

Enigma
Site Admin
Posts: 2652
Joined: Wed Aug 20, 2008 2:24 pm

Re: OCX not found when run on Virtual Machine

Post by Enigma » Wed Jun 23, 2021 10:45 am

For correct OCX registration you need to do two mandatory things:
1. In the file properties of this OCX set the option "Register as ActiveX"
2. Enable registry virtualization.

Check this tutorial: http://www.softwareprotection.info/2012 ... rivileges/

gibra
Posts: 10
Joined: Tue Nov 04, 2014 8:10 pm

Re: OCX not found when run on Virtual Machine

Post by gibra » Wed Jun 23, 2021 1:02 pm

Thanks for the quick reply.
The OCX file is set up just as shown in the your tutorial, as images below:

What's wrong?

Image

Image
Please note that the others libraries (DLL) are not ActiveX, so I not set as Register as Activex

Image

When execute the program in a VM (VMWare Windows 10) I get the error:

Image

Enigma
Site Admin
Posts: 2652
Joined: Wed Aug 20, 2008 2:24 pm

Re: OCX not found when run on Virtual Machine

Post by Enigma » Wed Jun 23, 2021 2:19 pm

Everything looks well.

Can you try to put OCX files in System or Windows folder, instead of Default folder?

If this won't help, please send us non packed files at support@enigmaprotector.com, we will check it out.

gibra
Posts: 10
Joined: Tue Nov 04, 2014 8:10 pm

Re: OCX not found when run on Virtual Machine

Post by gibra » Wed Jun 23, 2021 3:55 pm

I tried with both SYSTEM and WINDOWS folder, same error.
Exactly which files should they send to support?
1- .enigma project
2- Appplication test.exe
3- OCX and DLL

Thank you.


Post Reply