Page 1 of 1

Possible VC++ Plugin Bug?

Posted: Wed Sep 10, 2014 6:09 am
by Ledz
Using the latest The Enigma Protector version, trying to add a test plugin compiled using Visual C++ (VS 2013) and copying it inside the Plugin directory sometimes makes the protector not to load at all, and if it loads it seems it's attaching to the protector's process upon execute.

Not sure if it's just my code or I'm doing it wrong but I tried on 3 different computers running Windows 7 and 8.1, the result is the same, the only way I could get around the issue is by renaming currently working and detected plugin to make it show in the list then run the protector, and copy paste my test plugin file over the dummy one.

Note that the test plugin DLL works as it should, the only problem is what's mentioned above.

I have sent this issue already to the support email address but I guess I can't get a reply with just that, I decided to better post here as well to get some attention, thanks!

Re: Possible VC++ Plugin Bug?

Posted: Thu Sep 11, 2014 7:09 am
by Enigma
Problem relates to this particular plugin only, it does not belong to Enigma Protector.

Re: Possible VC++ Plugin Bug?

Posted: Thu Sep 11, 2014 3:26 pm
by Ledz
Yes, problem solved, thank you for the help.